summaryrefslogtreecommitdiff
path: root/external/opusfile-0.8/CMakeLists.txt
diff options
context:
space:
mode:
authorIronClawTrem <louie.nutman@gmail.com>2020-02-16 03:40:06 +0000
committerIronClawTrem <louie.nutman@gmail.com>2020-02-16 03:40:06 +0000
commit425decdf7e9284d15aa726e3ae96b9942fb0e3ea (patch)
tree6c0dd7edfefff1be7b9e75fe0b3a0a85fe1595f3 /external/opusfile-0.8/CMakeLists.txt
parentccb0b2e4d6674a7a00c9bf491f08fc73b6898c54 (diff)
create tremded branch
Diffstat (limited to 'external/opusfile-0.8/CMakeLists.txt')
-rw-r--r--external/opusfile-0.8/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/external/opusfile-0.8/CMakeLists.txt b/external/opusfile-0.8/CMakeLists.txt
new file mode 100644
index 0000000..48a2850
--- /dev/null
+++ b/external/opusfile-0.8/CMakeLists.txt
@@ -0,0 +1,24 @@
+add_library(
+ opusfile STATIC
+ include/opusfile.h
+ src/http.c
+ src/info.c
+ src/internal.c
+ src/internal.h
+ src/opusfile.c
+ src/stream.c
+ src/wincerts.c
+ src/winerrno.h
+ )
+
+include_directories(
+ include
+ ${CMAKE_CURRENT_SOURCE_DIR}/../opus-1.1.4/include
+ ${CMAKE_CURRENT_SOURCE_DIR}/../libogg-1.3.2/include
+ )
+
+target_link_libraries(
+ opusfile
+ opus
+ ogg
+ )