summaryrefslogtreecommitdiff
path: root/external/opus-1.1.4/silk/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/opus-1.1.4/silk/CMakeLists.txt')
-rw-r--r--external/opus-1.1.4/silk/CMakeLists.txt113
1 files changed, 113 insertions, 0 deletions
diff --git a/external/opus-1.1.4/silk/CMakeLists.txt b/external/opus-1.1.4/silk/CMakeLists.txt
new file mode 100644
index 0000000..932ffb4
--- /dev/null
+++ b/external/opus-1.1.4/silk/CMakeLists.txt
@@ -0,0 +1,113 @@
+# CMakeLists.txt in silk
+
+SET(SILK_SRCS
+A2NLSF.c
+ana_filt_bank_1.c
+biquad_alt.c
+bwexpander.c
+bwexpander_32.c
+check_control_input.c
+CNG.c
+code_signs.c
+control_audio_bandwidth.c
+control_codec.c
+control_SNR.c
+debug.c
+decoder_set_fs.c
+decode_core.c
+decode_frame.c
+decode_indices.c
+decode_parameters.c
+decode_pitch.c
+decode_pulses.c
+dec_API.c
+encode_indices.c
+encode_pulses.c
+enc_API.c
+gain_quant.c
+HP_variable_cutoff.c
+init_decoder.c
+init_encoder.c
+inner_prod_aligned.c
+interpolate.c
+lin2log.c
+log2lin.c
+LPC_analysis_filter.c
+LPC_inv_pred_gain.c
+LP_variable_cutoff.c
+NLSF2A.c
+NLSF_decode.c
+NLSF_del_dec_quant.c
+NLSF_encode.c
+NLSF_stabilize.c
+NLSF_unpack.c
+NLSF_VQ.c
+NLSF_VQ_weights_laroia.c
+NSQ.c
+NSQ_del_dec.c
+pitch_est_tables.c
+PLC.c
+process_NLSFs.c
+quant_LTP_gains.c
+resampler.c
+resampler_down2.c
+resampler_down2_3.c
+resampler_private_AR2.c
+resampler_private_down_FIR.c
+resampler_private_IIR_FIR.c
+resampler_private_up2_HQ.c
+resampler_rom.c
+shell_coder.c
+sigm_Q15.c
+sort.c
+stereo_decode_pred.c
+stereo_encode_pred.c
+stereo_find_predictor.c
+stereo_LR_to_MS.c
+stereo_MS_to_LR.c
+stereo_quant_pred.c
+sum_sqr_shift.c
+tables_gain.c
+tables_LTP.c
+tables_NLSF_CB_NB_MB.c
+tables_NLSF_CB_WB.c
+tables_other.c
+tables_pitch_lag.c
+tables_pulses_per_block.c
+table_LSF_cos.c
+VAD.c
+VQ_WMat_EC.c
+)
+
+SET(SILK_HEADERS
+API.h
+control.h
+debug.h
+define.h
+errors.h
+Inlines.h
+MacroCount.h
+MacroDebug.h
+macros.h
+main.h
+pitch_est_defines.h
+PLC.h
+resampler_private.h
+resampler_rom.h
+resampler_structs.h
+SigProc_FIX.h
+structs.h
+tables.h
+tuning_parameters.h
+typedef.h
+)
+
+INCLUDE_DIRECTORIES(
+ ${OPUS_INCLUDES_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_CURRENT_SOURCE_DIR}/../celt
+ ${CMAKE_CURRENT_SOURCE_DIR}/float
+ ${CMAKE_CURRENT_SOURCE_DIR}/fixed
+ )
+
+set ( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c11" )