Age | Commit message (Collapse) | Author |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
- move ClientGradualFunds() call before death check
- use pers.funds in game code, sync PERS_CREDIT only when necessary
|
|
|
|
|
|
|
|
- now always prioritizes poor players
- synchronizes PERS_CREDIT once per loop, instead of constantly
additionally, rename:
- G_AddCreditToClient -> G_AddFundsToClient
- G_OverflowCredits -> G_OverflowFunds
- 'credit(s)' parameters -> 'funds'
|
|
|
|
- rewrite and optimize G_AddCreditToClient()
- remove unclaimedFrags trashcode in player_die
Overflowing of fractional evos is supported; sharing isn't (yet?)
|
|
|
|
|
|
I'm getting sick and tired of these anti-documenting variable names. I hope this is the last fucking patch.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
I had forgotten Tremulous didn't like printing double quotes.
|